Foro de Mensajes

Avalon Software - Encanta - VagoBlog

No olvides leer las normas

 F.A.Q.F.A.Q.   Lista de MiembrosLista de Miembros   Grupos de UsuariosGrupos de Usuarios 
 PerfilPerfil   Conéctese para revisar sus mensajesConéctese para revisar sus mensajes   
 BuscarBuscar   RegístreseRegístrese ConectarseConectarse 

Duda sobre amithlon

 
Publicar Nuevo Tema   Responder al Tema    Índice del Foro Foro de Mensajes -> Amithlon
Ver tema anterior :: Ver siguiente tema  
Autor Mensaje
AnonimoX



Registrado: 12 Abr 2009
Mensajes: 21

MensajePublicado: Dom Abr 12, 2009 6:41 pm
   Título del mensaje: Duda sobre amithlon
Responder citando

Buenas, mi segundo post y ya estoy preguntando, pues bien debido a precio de los amiga 4000 con aceleradora y demas y teniendo dos pcs abandonados (un amd 3000 con una voodoo 4500 y un PIV a 2600 con una nvidia fx 5200) me he leido como instalar amithlon y bueno mas o menos me ha quedado claro, hay que hacer una particion pequeña de ms-dos por ejemplo poner ahi los archivos que arrancan el emu y crear la particion para el AmigaOS y depues instalar el amiga os 3.9 mi pregunta es ya que tengo que comprar el os. ¿me valdria tambien el os 4 o tiene que ser el os 3.9? y otra cosa en amiga os como se argan los juegos del amiga 500?

Gracias
Volver arriba
Ver perfil del usuario Enviar mensaje privado
ignavago
Site Admin


Registrado: 12 Oct 2004
Mensajes: 1777
Ubicación: Madrid

MensajePublicado: Lun Abr 13, 2009 3:27 am
   Título del mensaje:
Responder citando

No sé mucho sobre Amithlon (nunca he manejado uno), y si alguien mas puede aportar algo más de luz, quizás nos pueda ayudar más. Sonrisa

El AmigaOS 4 está preparado para PowerPC, mientras que el Amithlon funciona bajo x86, por lo que no creo que sea posible instalar en el Amithlon un AmigaOS 4 a no ser que lo recompilen totalmente.

Amithlon que yo sepa no tiene emulación de los custom chips, y tanto el sonido como los gráficos van por los sistemas retargeteables (AHI para el sonido y RTG/Picasso96 para el vídeo), no obstante creo que Amithlon es una especie de "emulación a lo bestia" usando hardware y un núcleo emulador preparado (¿microkernel?), pero podría estar algo equivocado.

En cualquier caso, supongo que para poder poner software antiguo (en especial juegos) me supongo que será necesario algún tipo de emulación bajo Amithlon (¿UAE para Amiga?)
_________________
Saludos...
Ignacio Gallego Puyol -- Vago / Avalon Software
Principal responsable de "El Amiga me Encanta"
Volver arriba
Ver perfil del usuario Enviar mensaje privado Enviar correo Visitar sitio web del autor
AnonimoX



Registrado: 12 Abr 2009
Mensajes: 21

MensajePublicado: Lun Abr 13, 2009 4:13 am
   Título del mensaje:
Responder citando

ignavago escribió:


El AmigaOS 4 está preparado para PowerPC, mientras que el Amithlon funciona bajo x86, por lo que no creo que sea posible instalar en el Amithlon un AmigaOS 4 a no ser que lo recompilen totalmente.


Entonces el 3.9 no tiene nada que ver con el 4.0 o 4.1
Volver arriba
Ver perfil del usuario Enviar mensaje privado
ignavago
Site Admin


Registrado: 12 Oct 2004
Mensajes: 1777
Ubicación: Madrid

MensajePublicado: Lun Abr 13, 2009 1:34 pm
   Título del mensaje:
Responder citando

Del 1.x al 3.9 están hechos para la arquitectura Motorola MC680x0 Lo que hoy se denomina en Amiga, los Amiga Classic.

Del 4.0 al 4.1 están hechos para PowerPC (para la placa AmigaOne A1 y posteriores diseños), en teoría para que también funcionen en los Amiga Classic que estuvieran dotados con tarjetas aceleradoras PowerPC, pero usando lo máximo posible este último procesador, y dejando de utilizar la generación anterior.

El futuro 5.0 (que ya no se sabe si va a salir, por lo que se) debería contener todo lo anterior (o lo mas "emulable posible" para utilizarlo, y todo lo nuevo incluyendo el AmigaDE integrado. Pero parece ser que no debería depender de procesador, lógicamente (como pasa con toda la informática) para equipos que estén preparados para ello.

El AmigaDE es una especie de "núcleo Java" preparado para funcionar en una gran gama de procesadores y máquinas. AmigaDE salió antes del AmigaOS4, y cuando salió el plan del 4.0 era poder unir a los equipos actuales con tarjetas modernas (procesador PPC) para poder utilizar "como programa" la tecnología de AmigaDE, y así el conjunto de los que todavía estaban en la comunidad de Amiga que también pudieran acceder a lo nuevo. En plan punto de unión para que fueran adoptando poco a poco el nuevo camino. Vamos para que no fuera tan traumático el paso de un lado a otro.

Así que si tu plan es poner el Amithlon y el AmigaOS4, por lo que yo sé no vas a poder. Tendrás que conformarte con el 3.9 y dejarlo ahí. No olvidemos que el Amithlon tuvo problemas legales y por eso no ha seguido desarrollándose como debiera. Si planeas utilizar el AmigaOS4 debería mirar placas que lo soporten (Amiga Classic con aceleradoras PPC, AmigaOne A1, creo que placas Pegasos de bPlan o bien la placa Samantha SAM440 de Acube System).

Si hay algo que no esté bien explicado, por favor echad mas luz al asunto, esto es lo que yo se por lo que he podido leer de las noticias y revistas que estoy pasando (mucha información venía en las Mundo Amiga, y haberlas transcrito todas es lo que tiene que se aprende mucha cultura amiguera... Complice ).
_________________
Saludos...
Ignacio Gallego Puyol -- Vago / Avalon Software
Principal responsable de "El Amiga me Encanta"
Volver arriba
Ver perfil del usuario Enviar mensaje privado Enviar correo Visitar sitio web del autor
AnonimoX



Registrado: 12 Abr 2009
Mensajes: 21

MensajePublicado: Lun Abr 13, 2009 3:16 pm
   Título del mensaje:
Responder citando

Ok todo claro, he estado mirando las PB y al final he encontrado una amigaone a 1000 mgzh pero muy cara eso si nueva a estrenar tambien me estoy planteando el pillar una sam440 aunque lo que me tira para atras de estas placas es la retrocompatibilidad y me lo estoy pensando por que para usar todo lo de amiga clasic (para mi el 500 y el 600) tendria que usar el uae pa el amigaos y para hacer eso ya tengo mi mac con osx 10.5.6 y el e-uae que va de muerte por ahora lo que voy a hacer es ampliar mi 500 con hd lo maximo que pueda (mem y acaleradoras) y ya vere si paso a ppc por ahora con el mac y con un pc con ubuntu tuning (kernel a medida de mi micro y componentes) me llega, tambien se me ha estado pasando otra cosa por la cabeza pero....... yo soy teleco y pensaba en diseñar una placa ppc con todo lo necesario para ser retrocompatible a nivel de hard es mucho curro y no tengo apenas documentacion a si que ya vere si me pongo a ello
Volver arriba
Ver perfil del usuario Enviar mensaje privado
ignavago
Site Admin


Registrado: 12 Oct 2004
Mensajes: 1777
Ubicación: Madrid

MensajePublicado: Lun Abr 13, 2009 3:29 pm
   Título del mensaje:
Responder citando

El problema es que tu no solo buscas algo que sea compatible con lo antiguo (que ya hay, se llama Minimig y es "relativamente barato" o fácil de construir incluso si quieres hacerlo tu).

El problema es que quieres que también sea compatible con lo moderno. Y un ordenador compatible con todo nunca ha existido, en ninguna plataforma o sistema operativo. Siempre habrá algún tipo de porcentaje (justo aquella utilidad o juego que te interesa) que no carga. Sonrisa

Que sepas que si amplias el Amiga 500 con disco duro y máximo de memoria, que hay cierto porcentaje de juegos y software que no es compatible con todos los adelantos. De hecho esto también pasó con cierto porcentaje de software que no se ejecutaba bien bajo los Amiga AGA, precisamente por las diferencias de arquitectura y porque algunos programadores no hacían caso de las "normas de programación" que Commodore daba en su día para compatibilizarlos lo máximo posible.
_________________
Saludos...
Ignacio Gallego Puyol -- Vago / Avalon Software
Principal responsable de "El Amiga me Encanta"
Volver arriba
Ver perfil del usuario Enviar mensaje privado Enviar correo Visitar sitio web del autor
AnonimoX



Registrado: 12 Abr 2009
Mensajes: 21

MensajePublicado: Mie Abr 15, 2009 5:28 pm
   Título del mensaje:
Responder citando

Eso ya lo se, pero a lo que merefiero es aquellos juegos de amiga 500 que me marcaron, (lease defender of thr crown norte y sur xenon etc) me gustaria jugarlos directamente desde el disquete o instalarlos en el hd del amiga (4000) o la sam440y no tener que usar emulacion ninguna en el caso de los pc la retrocompatibilidad es altisima (cerca de 90% de lo que se usaba en un 8086 funciona en xp o vista) y en mac pasa lo mismo hasta que "nos mudamos a intel" aun asi hay retrocompatibilidad con algunos programas bajadonte solo un parche para ejecutarlos Complice es a eso a lo que me referia, lo de hacer un sistema retrocompatible al 100% son elucubraciones de un abuelo en plena senilidad ja ja ja para pillar el minimig me quedo con el 500 lo que quiero es usar cualquier otro como un 500 y dandole mas posibilidades (net sobre todo) yo es que en el fondo me gusta exprimir al maximo la maquinas antigua (notese que digo antiguas no viejas) si no de que iba a tener yo como mi coche para mi, no para la familia, un golf gti 16v serie 2? o por que sigo con un nokia 8810 o una palm soy un sentimental y ademas si todavia encienden se les puede sacar mucho partido je je je fijate si me gustara lo antiguo qeu yo escucho los cd en gramola y siempre suenan igual "gieufhufdsgfhsgshfds "(sera por eso que me llaman carca por que no se cantar el ultimo exito de melendi? bueno lo dicho yo intento a ver que sale Complice gracias por todo
Volver arriba
Ver perfil del usuario Enviar mensaje privado
Mostrar mensajes anteriores:   
Publicar Nuevo Tema   Responder al Tema    Índice del Foro Foro de Mensajes -> Amithlon Todas las horas están en GMT + 2 Horas
Página 1 de 1

 
Saltar a:  
No puede crear mensajes
No puede responder temas
No puede editar sus mensajes
No puede borrar sus mensajes
No puede votar en encuestas


Powered by phpBB © 2001, 2005 phpBB Group